Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Forum Statistics
» Members: 304
» Latest member: hairmillion
» Forum threads: 78
» Forum posts: 363

Full Statistics

Online Users
There are currently 19 online users.
» 0 Member(s) | 19 Guest(s)

Latest Threads
FreeRTOS on Xilinx/Xen no...
Forum: Public Support
Last Post: BurchSung
05-25-2018, 05:08 PM
» Replies: 4
» Views: 1,232
Error kernel paging reque...
Forum: Public Support
Last Post: ariefgrand
02-14-2018, 03:19 PM
» Replies: 1
» Views: 1,403
XZD 2017.1 Release
Forum: Knowledge Base
Last Post: Nathan.Studer
02-12-2018, 03:12 PM
» Replies: 0
» Views: 604
XZD is Now Virtuosity
Forum: Knowledge Base
Last Post: Nathan.Studer
02-12-2018, 03:09 PM
» Replies: 0
» Views: 394
Forum: Knowledge Base
Last Post: Nathan.Studer
02-12-2018, 02:53 PM
» Replies: 3
» Views: 840
Embedded Virtualization E...
Forum: Knowledge Base
Last Post: Nathan.Studer
02-12-2018, 02:34 PM
» Replies: 0
» Views: 344
How can we compile libvch...
Forum: Public Support
Last Post: Nathan.Studer
01-24-2018, 01:22 PM
» Replies: 9
» Views: 2,841
DomU I/O and Communicatio...
Forum: Public Support
Last Post: ariefgrand
01-08-2018, 05:02 PM
» Replies: 11
» Views: 6,545
DMA from DomU on ZynqMP
Forum: Public Support
Last Post: ariefgrand
12-12-2017, 09:18 AM
» Replies: 2
» Views: 1,604
DomU and PL on ZCU102 Zyn...
Forum: Public Support
Last Post: Nathan.Studer
12-11-2017, 02:12 PM
» Replies: 1
» Views: 1,163

  ZCU102 dev kit not able to boot with xen hypervisor
Posted by: paresh.chaudhary - 02-08-2017, 10:08 PM - Forum: Public Support - Replies (4)


Before go ahead i am trying to boot pre-build images on zcu102 devkit. For that i am referring 4.2.2. Booting via SD card. But i don't why board is stuck on uboot.

I have attached boot log. Can anybody have idea about this ?

Attached Files
.txt   bootlog.txt (Size: 1.69 KB / Downloads: 7)
Print this item

  Mapping physical peripherals through to guests without any dom0 interaction
Posted by: paresh.chaudhary - 02-02-2017, 08:20 PM - Forum: Public Support - Replies (5)


I want to isolate dedicated hardware or memory range from a Guest os to the processor peripheral without going through DOM0 on ZYNQ MPSOC.

How it's possible in Xen hypervisor ?

Print this item

  "make dist-tools" from inside a VM with controlled Internet access
Posted by: BraetonTaylor - 01-26-2017, 08:47 PM - Forum: Public Support - Replies (3)

When doing the command:

cd $PROJ_DIR/$PROJ_NAME/components/apps/xen/xen-src
make dist-tools CROSS_COMPILE=aarch64-buildroot-linux-gnu- XEN_TARGET_ARCH=arm64 CONFIG_EARLY_PRINTK=ronaldo

I get the following error:
   Cloning into 'qemu-xen-dir-remote.tmp'...
   fatal: unable to connect to xenbits.xen.org:
   xenbits.xen.org: Name or service not known
when it is running "/disk2/XZD/XenDOM0/components/apps/xen/xen-src/tools/../scripts/git-checkout.sh git://xenbits.xen.org/qemu-xen.git qemu-xen-4.7.0-rc4 qemu-xen-dir"

To make the system use http instead of git, I can update file "components/apps/xen/xen-src/Config.mk" and add line "export GIT_HTTP=y" just before line with "ifeq ($(GIT_HTTP),y)".

Then I get this:
   Cloning into 'qemu-xen-dir-remote.tmp'...
   fatal: unable to access 'http://xenbits.xen.org/git-http/qemu-xen.git/': Could not resolve host: xenbits.xen.org
when it is running "/disk2/XZD/XenDOM0/components/apps/xen/xen-src/tools/../scripts/git-checkout.sh http://xenbits.xen.org/git-http/qemu-xen.git/ qemu-xen-4.7.0-rc4 qemu-xen-dir"

Note the use of http: and git-http now.

To fix this error, I can define these:
  export http_proxy=<Company Proxy Server with my User Name and Password>
  export https_proxy=<Company Proxy Server with my User Name and Password>

Then I get this, this is how it should look:
  Cloning into 'qemu-xen-dir-remote.tmp'...
  remote: Counting objects: 302654, done.
  remote: Compressing objects: 100% (72963/72963), done.
  remote: Total 302654 (delta 245259), reused 284315 (delta 228934)
  Receiving objects: 100% (302654/302654), 96.06 MiB | 2.33 MiB/s, done.
  Resolving deltas: 100% (245259/245259), done.
  Checking connectivity... done.

However, I cannot use this as final solution, as putting my user name and password into a script or even environment variables is not allowed.  Any suggestions on how to fix this?  Ideally, I would like to download all the components that I need ahead of time, put them into a Zip files and just unzip them instead of downloading them.

Print this item

  XZD_20161231 Release
Posted by: jarvis_roach - 01-09-2017, 03:59 PM - Forum: Knowledge Base - Replies (3)

DornerWorks is pleased to announce the XZD_20161231 release of XZD!

XZD Package:  http://dornerworks.com/wp-content/upload...161231.tgz
User's Manual:  http://dornerworks.com/wp-content/upload...Manual.pdf

New Features
Support for Petalinux v2016.3
Xen virtual console support for bare metal guests
Updated Ethernet passthrough for bare metal guest examples
Added support for Ubuntu 16.04 hosts

Print this item

  Xilinx PetaLinux 2016.3 and XZD
Posted by: BraetonTaylor - 12-21-2016, 03:53 PM - Forum: Knowledge Base - Replies (1)

Are there any updates to XZD required to use it with Xilinx PetaLinux 2016.3?  The latest version I see of XZD is 20160930, which is before PetaLinux 2016.3.

Print this item

  ARINC 653 Scheduling Utility
Posted by: Nathan.Studer - 12-12-2016, 09:30 PM - Forum: Knowledge Base - No Replies

To make using the ARINC 653 scheduler with XZD easier, we have posted the source code to a Xen ARINC653 command line scheduling utility to github.  Instructions for building it with the XZD distribution and for using it can be found in the README.



Print this item

  How do you start Guests automatically?
Posted by: BraetonTaylor - 11-30-2016, 01:43 PM - Forum: Public Support - Replies (5)

How do you start Guests automatically?  I tried this on the target, but it did not work. 
    cd /etc/xen/auto
    ln -s /root/Dom1_Linux.cfg .
I tried adding these to the .cfg file as well:
    on_xend_stop = ‘shutdown’
    on_xend_start = ‘start’


Print this item

  Xen distribution for Zynq-7000
Posted by: lar_fer - 11-19-2016, 09:24 AM - Forum: Public Support - Replies (2)


I was wandering if there is a Xen Distribution for the Zynq-7000 device family.

If anyone one knows about a project for Zynq-7000, please let me know.



Print this item

  Building XZD without an Internet connection
Posted by: BraetonTaylor - 11-02-2016, 07:42 PM - Forum: Public Support - Replies (7)

The XZD BSP petalinux-build (Section 5.2  step 5 of the Xen Zynq Distribution User’s Manual 
(Xilinx-XenZynq-DOC-0001 v0.7 July 1, 2016)) produces an error if you do not have an Internet connection.

I tracked this down to the petalinux-config, it has u-boot config set as "remote", with remote set to "https://github.com/dornerworks/u-boot-xlnx.git".
This will not work unless connected to the network.  What is the alternative?  Can I downloaded it separately and put it some place and point to that?
If so, where do I put it and how do I point to it?  It does build if I change this to "u-boot-plnx", but I am guessing that I will be missing some 
capability in the U-BOOT application.  Do all I lose is the "run xen" command?

See log of build attempt:

210053673@synergy-dev-x64:~$ source /opt/pkg/petalinux-v2016.2-final/settings.sh
PetaLinux environment set to '/opt/pkg/petalinux-v2016.2-final'
INFO: Checking free disk space
INFO: Checking installed tools
INFO: Checking installed development libraries
INFO: Checking network and other services
WARNING: No tftp server found - please refer to "PetaLinux SDK Installation Guide" for its impact and solution

210053673@synergy-dev-x64:~$ export RELEASE_DIR=/opt/XZD/XZD_20160930

210053673@synergy-dev-x64:~$ cd $RELEASE_DIR

210053673@synergy-dev-x64:/opt/XZD/XZD_20160930$ petalinux-create -t project -s /opt/XZD/XZD_20160930/XZD_20160930.bsp -n XenZynqDist2
INFO: Create project: XenZynqDist2
INFO: New project successfully created in /opt/XZD/XZD_20160930/XenZynqDist2

210053673@synergy-dev-x64:/opt/XZD/XZD_20160930$ cd $RELEASE_DIR/XenZynqDist2

210053673@synergy-dev-x64:/opt/XZD/XZD_20160930/XenZynqDist2$ petalinux-build
INFO: Checking component...
INFO: Generating make files and build linux
INFO: Generating make files for the subcomponents of linux
INFO: Checking if the remote url is a valid git remote repository!
ERROR: https://github.com/dornerworks/u-boot-xlnx.git is not a git repository
ERROR: Failed to get remote component linux/u-boot!
ERROR: Failed to get remote component linux/u-boot!
ERROR: Failed to get makefiles for subcomponents of linux
ERROR: Failed to build linux! Failed to get makefiles for subcomponents of linux!

Print this item

  FIT Image file handling
Posted by: john_dino_dinatale - 11-01-2016, 01:18 PM - Forum: Public Support - Replies (7)


I went through this document:
And I have a uImage.its, which was able to create a uImage.itb. When I use the “bootm” command, I get the following:
U-Boot-E6Kn>bootm 0x6000000:xen@1
Wrong Image Format for bootm command
ERROR: can't get kernel image!
I’m using “xen.ub”, for the node image. Is this the correct file?

I tried to attach my ".its" file, but couldn't, because of a file format problem. I'll attach it when I figure out how to? Huh


Print this item