Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kernel Panic
I am using Xen Zynq Distribution, following user Manual (Xilinx-XenZynq-DOC-0001 v0.7 July 1, 2016).

During step after "run xen" command, linux boots but results in kenel panic.

 Attached are logs, Please suggest what went wrong.


Attached Files
.txt   kernel_panic.txt (Size: 29.26 KB / Downloads: 9)
Hello Sunit,

Sorry that you're having trouble, it looks like there's something wrong with your rootfs.

In particular the message from Linux in your boot log says "VFS: Mounted root (vfat filesystem) readonly on device 179:1." indicating that your file system on mmcblk0p1 of your SD card is "vfat", this should be "ext4" for the rootfs.

What commands did you use to populate your SD card?  You may want to try repeating 4.2.1 step 1 to make sure that the dom0 file system image was correctly copied to your SD card.

- Josh
Hello Josh,

Thanks, 4.2.1 step 1 in user manual was not getting success in writing image to SD card. I think the SD card was formatted from windows PC so I re-formatted SD card from ubuntu machine (ext4) and repeated step 1 of 4.2.1 and finally dom0 comes up successfully.

I am having this exact same issue, but cannot seem to resolve it.  I am booting entirely from the SD card (not using JTAG).  I followed the directions for this in the Xen Zynq Distribution User’s Manual (July 1, 2016), section 4.2.2.  I am using the XZD_20160930 release on a ZCU102 RevB board.  I tried formatting the SD card with the following commands:

umount /dev/sdb1
sudo mkfs.ext4 /dev/sdb1

umount /dev/sdb2
sudo mkfs.ext4 /dev/sdb2

Then putting the contents on the SD card via section 4.2.2, using the pre-made images.
I also tried making /dev/sdb1 a vfat with the command "sudo mkfs.vfat /dev/sdb1".

Do I need to format /dev/sdb?
I am using a 32GB SanDisk UtralPlus SDHC UHS-1 Card.  I am able to boot my Linux image that I build using the PetaLinux tools chain on the SD card.

I attached the output of the load/boot.


Attached Files
.txt   XZD_Boot_Term_Output2_log.txt (Size: 28.97 KB / Downloads: 0)
My issue has been solved.  The system was looking for the root FS in mmcblk0p1 because that is how the pre-made xen.dtb file ($RELEASE_DIR/dist/images/linux/xen-zcu102.dtb) is configured.  I updated the associated .dts and rebuilt the .dtb file as described in section steps 7 C and D (to use mmcblk0p2).  Then loaded that new version and it works.

Ideally, DornerWorks should provide both versions as pre-built and update the instructions for the SD boot to use the other one.
Also, some steps are missing "$RELEASE_DIR/" in them, so it only works if you are in the "$RELEASE_DIR" directory.


I'm glad to hear you got it working. We do provide a xen-sd.dts file in the $RELEASE_DIR/dts directory, but I agree that having a compiled DTB in the $RELEASE_DIR/dist/images/linux/ would be a good ting to have. Thank you for your feedback.



Forum Jump:

Users browsing this thread: 1 Guest(s)