Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Building XZD without an Internet connection
The XZD BSP petalinux-build (Section 5.2  step 5 of the Xen Zynq Distribution User’s Manual 
(Xilinx-XenZynq-DOC-0001 v0.7 July 1, 2016)) produces an error if you do not have an Internet connection.

I tracked this down to the petalinux-config, it has u-boot config set as "remote", with remote set to "".
This will not work unless connected to the network.  What is the alternative?  Can I downloaded it separately and put it some place and point to that?
If so, where do I put it and how do I point to it?  It does build if I change this to "u-boot-plnx", but I am guessing that I will be missing some 
capability in the U-BOOT application.  Do all I lose is the "run xen" command?

See log of build attempt:

210053673@synergy-dev-x64:~$ source /opt/pkg/petalinux-v2016.2-final/
PetaLinux environment set to '/opt/pkg/petalinux-v2016.2-final'
INFO: Checking free disk space
INFO: Checking installed tools
INFO: Checking installed development libraries
INFO: Checking network and other services
WARNING: No tftp server found - please refer to "PetaLinux SDK Installation Guide" for its impact and solution

210053673@synergy-dev-x64:~$ export RELEASE_DIR=/opt/XZD/XZD_20160930

210053673@synergy-dev-x64:~$ cd $RELEASE_DIR

210053673@synergy-dev-x64:/opt/XZD/XZD_20160930$ petalinux-create -t project -s /opt/XZD/XZD_20160930/XZD_20160930.bsp -n XenZynqDist2
INFO: Create project: XenZynqDist2
INFO: New project successfully created in /opt/XZD/XZD_20160930/XenZynqDist2

210053673@synergy-dev-x64:/opt/XZD/XZD_20160930$ cd $RELEASE_DIR/XenZynqDist2

210053673@synergy-dev-x64:/opt/XZD/XZD_20160930/XenZynqDist2$ petalinux-build
INFO: Checking component...
INFO: Generating make files and build linux
INFO: Generating make files for the subcomponents of linux
INFO: Checking if the remote url is a valid git remote repository!
ERROR: is not a git repository
ERROR: Failed to get remote component linux/u-boot!
ERROR: Failed to get remote component linux/u-boot!
ERROR: Failed to get makefiles for subcomponents of linux
ERROR: Failed to build linux! Failed to get makefiles for subcomponents of linux!

Theoretically, you will need to clone the Git repo, checkout the appropriate branch, and then use petalinux-config to point to the directory where you cloned the repo. However, u-boot may not be the only thing that needs to be downloaded, and this is not a use case that we've validated before.

git clone
cd u-boot-xlnx
git checkout dw-v2016.2

In petalinux-config, I would try changing "git://" to point your local copy of the repo, so something like "file://localhost/<path to local repo>", but we haven't tried this out ourselves yet.

There are some other patches/additions we have made to U-Boot, but you should be able to get going with the PLNX u-boot. The xen boot command won't be populated, but if you're booting up from an SD card you have a different set of commands to follow.


Also, when doing 5.3 step 3 (make), I get this error:

10053673@synergy-dev-x64:/opt/XZD/XZD_20160930/buildroot$ make
>>> host-gawk 4.1.0 Downloading
--2016-11-03 12:34:49--
Resolving ( failed: Name or service not known.
wget: unable to resolve host address ‘’
--2016-11-03 12:34:58--
Resolving ( failed: Name or service not known.
wget: unable to resolve host address ‘’
make: *** [/opt/XZD/XZD_20160930/buildroot/output/build/host-gawk-4.1.0/.stamp_downloaded] Error 1

I am guessing there will be more like this, as evidence from the below grep command output:

210053673@synergy-dev-x64:/opt/XZD/XZD_20160930/buildroot$ grep -nHIFs '' `find . -name "*"`
./package/lightning/ =
./package/libtasn1/ =
./ default ""
./output/build/buildroot-config/autoconf.h:41:#define BR2_GNU_MIRROR ""

Can I do 5.3: steps 1-5 just once while connected to the Network, then do the other steps only when the file system changes?  It does not look like these steps use anything from the project.
I get this same error when running from a VM on a machine that does have an Internet connection.  From within the VM I can get to "" in Firefox.  What do I need to do to get this make command to work?

We're seeing if we can reproduce the problem on our machines.



That step works for me. Does "wgets" work for you?

(11-04-2016, 02:13 PM)Braeton, Wrote: That step works for me. Does "wgets" work for you?


No I get:

$ wget
--2016-11-04 12:28:10--
Resolving ( failed: Name or service not known.
wget: unable to resolve host address ‘’
The issues seems to be the company network settings.  If I connect directly to an outside network then it works.  After about an hour and half, and many GBs of newly used VM disk space, I was able to complete steps 1-6 of section 5.3 (Build the Dom0 File System). 

Is this a one time thing?  Or will this need to be done repeatedly?

That should be a one time thing, as long as you don't "make clean" or otherwise delete the various repos.



Forum Jump:

Users browsing this thread: 1 Guest(s)