Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kernel panic when launching QEMU
#11
(05-18-2017, 07:29 AM)pello.heriz Wrote: Hi Nathan,

I have switch to the dw-v2016.4 branch and cloned the meta-xzd layer correctly. Anyway, I have tried to execute 'bitbake xzd-domu-image-minimal' command and I have a problem related with a license. Here it is:

ou can also run generated qemu images with a command like 'runqemu qemux86'
generalelectric@mlan11214m117linux:/opt/yocto_GE/poky/master/build$ bitbake xzd-domu-image-minimal
NOTE: /opt/yocto_GE/poky/master/meta-qt5/recipes-qt/qt5/qtbase_git.bb: base_contains is deprecated, please use bb.utils.contains instead.
NOTE: /opt/yocto_GE/poky/master/meta-qt5/recipes-qt/qt5/qtbase_git.bb: base_contains is deprecated, please use bb.utils.contains instead.
ERROR: /opt/yocto_GE/poky/master/meta-xzd/recipes-bsp/u-boot/u-boot-xlnx_xzd.bb: This recipe does not have the LICENSE field set (u-boot-xlnx)
ERROR: Failed to parse recipe: /opt/yocto_GE/poky/master/meta-xzd/recipes-bsp/u-boot/u-boot-xlnx_xzd.bb

What do I need to do in order to get that license or avoid this issue? Do I need to clone this https://github.com/Xilinx/u-boot-xlnx/tr...r/Licenses and add u-boot-xlnx to my bblayers or something similar to that?

Best regards,
Pello

Do you have the 'rel-v2016.4' branch of the meta-petalinuxmeta-xilinx, and meta-xilinx-tools layers included in your Yocto setup?  The meta-xzd layer is dependent on those layers.  In this case the base u-boot-xlnx information is defined in meta-xilinx and meta-xzd overrides select portions of it.

     Nate
Reply
#12
Hi Nathan,

I have solved the license issue, but I still have another error in order to compile the xen-domu-image-minimal. Here it is:

generalelectric@mlan11214m117linux:/opt/yocto_GE/poky/master/build$ bitbake xzd-domu-image-minimal
Loading cache: 100% |############################################| Time: 0:00:00
Loaded 1341 entries from dependency cache.
WARNING: /opt/yocto_GE/poky/master/meta-petalinux/recipes-external/external-xilinx-toolchain/libgcc-xilinx.bb: LICENSE_libgcov-dev includes licenses (GPL-3.0) that are not listed in LICENSE
Parsing recipes: 100% |##########################################| Time: 0:01:34
Parsing of 2104 .bb files complete (1042 cached, 1062 parsed). 2888 targets, 198 skipped, 0 masked, 0 errors.
WARNING: No recipes available for:
/opt/yocto_GE/poky/master/meta-petalinux/recipes-devtools/python/python-smartpm_%.bbappend
/opt/yocto_GE/poky/master/meta-xzd/recipes-devtools/python/python3_3.5.1.bbappend
/opt/yocto_GE/poky/master/meta-xzd/recipes-kernel/linux/linux-xlnx_4.6.bbappend
NOTE: Resolving any missing task queue dependencies
ERROR: Nothing RPROVIDES 'nativesdk-smartpm' (but /opt/yocto_GE/poky/master/meta/recipes-core/meta/buildtools-tarball.bb RDEPENDS on or otherwise requires it)
NOTE: Runtime target 'nativesdk-smartpm' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['nativesdk-smartpm']
ERROR: Required build target 'xzd-domu-image-minimal' has no buildable providers.
Missing or unbuildable dependency chain was: ['xzd-domu-image-minimal', 'buildtools-tarball', 'nativesdk-smartpm']

Summary: There were 2 WARNING messages shown.
Summary: There were 2 ERROR messages shown, returning a non-zero exit code.
generalelectric@mlan11214m117linux:/opt/yocto_GE/poky/master/build$

Do you have any idea on what is happening?

Thanks,
Pello
Reply
#13
(05-19-2017, 08:12 AM)pello.heriz Wrote: WARNING: No recipes available for:
 /opt/yocto_GE/poky/master/meta-petalinux/recipes-devtools/python/python-smartpm_%.bbappend
 /opt/yocto_GE/poky/master/meta-xzd/recipes-devtools/python/python3_3.5.1.bbappend
 /opt/yocto_GE/poky/master/meta-xzd/recipes-kernel/linux/linux-xlnx_4.6.bbappend

Are you using the correct Yocto branches?  2016.4 only supports krogoth branches.  The easiest way to make sure you have all the appropriate layers is to follow the instructions here:

https://github.com/dornerworks/xzd-yocto-manifests

and then run 
Code:
source setupsdk

to setup the Yocto environment and/or create the default configs and the build directory.

     Nate
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)