Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Yocto image as domU
#11
(05-19-2017, 08:12 AM)pello.heriz Wrote: WARNING: No recipes available for:
 /opt/yocto_GE/poky/master/meta-petalinux/recipes-devtools/python/python-smartpm_%.bbappend
 /opt/yocto_GE/poky/master/meta-xzd/recipes-devtools/python/python3_3.5.1.bbappend
 /opt/yocto_GE/poky/master/meta-xzd/recipes-kernel/linux/linux-xlnx_4.6.bbappend

Are you using the correct Yocto branches?  2016.4 only supports krogoth branches.  The easiest way to make sure you have all the appropriate layers is to follow the instructions here:

https://github.com/dornerworks/xzd-yocto-manifests

and then run 
Code:
source setupsdk

to setup the Yocto environment and/or create the default configs and the build directory.

     Nate
Reply
#12
(05-19-2017, 02:36 PM)Nathan.Studer Wrote:
(05-19-2017, 08:12 AM)pello.heriz Wrote: WARNING: No recipes available for:
 /opt/yocto_GE/poky/master/meta-petalinux/recipes-devtools/python/python-smartpm_%.bbappend
 /opt/yocto_GE/poky/master/meta-xzd/recipes-devtools/python/python3_3.5.1.bbappend
 /opt/yocto_GE/poky/master/meta-xzd/recipes-kernel/linux/linux-xlnx_4.6.bbappend

Are you using the correct Yocto branches?  2016.4 only supports krogoth branches.  The easiest way to make sure you have all the appropriate layers is to follow the instructions here:

https://github.com/dornerworks/xzd-yocto-manifests

and then run 
Code:
source setupsdk

to setup the Yocto environment and/or create the default configs and the build directory.

     Nate

Hi Nate,

I'm trying to boot the pre-compiled FreeRTOS image on QEMU once Xen and Dom0 are launched, by following the steps given in the next link: http://xzdforums.dornerworks.com/attachment.php?aid=18.

I'm able to create the freertos domain and if I run "xl list" command, I can see that both domains are working:

root@plnx_aarch64:/root# xl list
Name                                        ID   Mem  VCPU      State     Time(s)
Domain-0                                   0     768      1            r-----     123.2
freertos                                      1       8        1            r-----     131.1

Anyway, when I try to connect to the freertos console using "xl console <domain-name>" or directly creating the domain using "xl create -c /etc/xen/freertos.cfg", QEMU gets stuck outputting the next sentence:

root@plnx_aarch64:/root# xl create -c /etc/xen/freertos.cfg
Parsing config from /etc/xen/freertos.cfg

How can I solve this issue? Is the error related to QEMU or to FreeRTOS image?

Best regards,
Pello
Reply
#13
(07-11-2017, 07:35 AM)pello.heriz Wrote:
(05-19-2017, 02:36 PM)Nathan.Studer Wrote:
(05-19-2017, 08:12 AM)pello.heriz Wrote: WARNING: No recipes available for:
 /opt/yocto_GE/poky/master/meta-petalinux/recipes-devtools/python/python-smartpm_%.bbappend
 /opt/yocto_GE/poky/master/meta-xzd/recipes-devtools/python/python3_3.5.1.bbappend
 /opt/yocto_GE/poky/master/meta-xzd/recipes-kernel/linux/linux-xlnx_4.6.bbappend

Are you using the correct Yocto branches?  2016.4 only supports krogoth branches.  The easiest way to make sure you have all the appropriate layers is to follow the instructions here:

https://github.com/dornerworks/xzd-yocto-manifests

and then run 
Code:
source setupsdk

to setup the Yocto environment and/or create the default configs and the build directory.

     Nate

Hi Nate,

I'm trying to boot the pre-compiled FreeRTOS image on QEMU once Xen and Dom0 are launched, by following the steps given in the next link: http://xzdforums.dornerworks.com/attachment.php?aid=18.

I'm able to create the freertos domain and if I run "xl list" command, I can see that both domains are working:

root@plnx_aarch64:/root# xl list
Name                                        ID   Mem  VCPU      State     Time(s)
Domain-0                                   0     768      1            r-----     123.2
freertos                                      1       8        1            r-----     131.1

Anyway, when I try to connect to the freertos console using "xl console <domain-name>" or directly creating the domain using "xl create -c /etc/xen/freertos.cfg", QEMU gets stuck outputting the next sentence:

root@plnx_aarch64:/root# xl create -c /etc/xen/freertos.cfg
Parsing config from /etc/xen/freertos.cfg

How can I solve this issue? Is the error related to QEMU or to FreeRTOS image?

Best regards,
Pello

Pello,

Does `CTRL-]` return you back to dom0's console?

The link has instructions for how you can modify the source code for enabling virtual console, but the pre-built image does have it enabled by default. You can configure QEMU to run with the second UART enabled by replacing '-serial /dev/null' with '-serial tcp::4444,server'. Then in another window 'telnet localhost 4444' once you start QEMU.


Regards,

-Jarvis
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)