Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Which qemu-system-aarch64 should be in path?
#1
Hello,
I've installed both XZD (2016.12.31) and the Xilinx SDK (2016.3), and am uncertain as to which of the following qemu-system-aarch64 binaries I should be using:
  • Debian system (v2.5.0)
  • Xilinx SDK (v2.2.50)
  • XZD tools/hsm/bin (v2.2.50)
  • XZD tools/linux-i386/petalinux/bin (v2.2.50)
Sourcing settings64.sh in the Xilinx SDK puts the Xilinx SDK version in my PATH, but text in the XZD user manual makes it sound as though I should be using the one that ships with XZD. The version numbers of the XZD/Xilinx binaries are actually indentical, but perhaps they're different builds? Any information would be greatly appreciated...
Thanks,
Brett S.
Reply
#2
(08-14-2017, 09:56 PM)brettstahlman Wrote: Hello,
I've installed both XZD (2016.12.31) and the Xilinx SDK (2016.3), and am uncertain as to which of the following qemu-system-aarch64 binaries I should be using:
  • Debian system (v2.5.0)
  • Xilinx SDK (v2.2.50)
  • XZD tools/hsm/bin (v2.2.50)
  • XZD tools/linux-i386/petalinux/bin (v2.2.50)
  • Xilinx's zynqmp QEMU changes have not made it upstream, so the Debian provided package would not work.
  • This is the primary one to use.
  • This is part of the Petalinux/Yocto build output.  It should match the XSDK qemu and can be used as well.
  • Same.
     Nate
Reply
#3
Understood!
Thanks,
Brett S.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)