Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FreeRTOS on Xilinx/Xen not starting
#1
Hi,



I am using Petalinux-v2017.3 and created the Xilinx project based on BSP: xilinx-zcu102-zu9-es2-rev1.0-v2017.3-final.bsp
I have Xen running on Xilinx ZCU-102 via QEMU, then I created the "Hello world" image (Cortex-A53) of FreeRTOS with the default SDK project following below doc:

https://www.freertos.org/RTOS-Xilinx-SDK-BSP.html

And built the image with below instructions:
http://xzdforums.dornerworks.com/attachment.php?aid=18

The configuration file content is:

name = "freertos" 
kernel = "freertos.img" 
memory = 8 
vcpus = 1 
cpus = [1] 
iomem = [ "0xff010,1"]


And start it with> xl create -c -f freertos.cfg

BUT it only prints the line: "Parsing config from freertos.cfg"

And nothing else happens, is there a way to debug the problem?
Reply
#2
Anyone that can shed some light here?
Reply
#3
The instructions you referenced are a bit out-of-date.  They should work for the most recent XZD release which corresponds to PetaLinux 2017.1, but will not work for PetaLinux 2017.3.  However, the 2017.3 compatible version of XZD should be released soon.

    Nate
Reply
#4
Thanks Nathan, makes sense, I am using 2017.3 :-(
Thanks for the clarification.
Reply
#5
Hi...i am a new user here. I want to know what exact error message you are seeing?
Can you petalinux-build -x mrproper to clean and rebuild?I am also trying to build the virtualization support on Zynqmp Ultrazed board.

pcba board
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)